sales@hackhalt.com

Home / Threats / CVE-2026-82845

Masteriyo LMS - Security Vulnerability (CVE-2026-82845)

CVE-2026-82845

The Masteriyo LMS WordPress plugin before 3.4.1 does not prevent user-supplied values held as metadata from being deserialized when they are read back, allowing users with a minimal account to inject arbitrary PHP objects and, by way of a class shipped in a library bundled with the Masteriyo LMS WordPress plugin before 3.4.1, write and execute arbitrary code on the server. A weaker form of the same issue is reachable without an account and yields an arbitrary file write rather than code execution.

CVE-2026-82845

CRITICAL CVSS 9.9 Published 2026-09-12 Updated 2026-09-14
AI Risk Critical (91/100) Active Exploit: No strong signal Published Exploit: No public exploit references Priority: P1 Immediate
Severity Band CRITICAL
CVSS Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Affected Components 1
Reference Links 1
AI Risk Engine Critical (91/100)
Exploitability High
Active Exploitation No strong signal
Published Exploit Status No public exploit references

Threat Timeline

  1. 2026-09-12 CVE published and first recorded in the threat feed.
  2. 2026-09-14 Record updated with latest vulnerability metadata.
  3. 2026-09-22 AI technical context refreshed for mitigation and impact guidance.
  4. Now Monitoring for follow-up changes, linked references, and new related CVEs.

AI Context

Machine-generated threat intelligence

AI Updated 44 days ago

AI enriched 44 days ago (2026-09-22 02:19 UTC)

Technical Summary

The Masteriyo LMS WordPress plugin before 3.4.1 does not prevent user-supplied values held as metadata from being deserialized when they are read back, allowing users with a minimal account to inject arbitrary PHP objects and, by way of a class shipped in a library bundled with the Masteriyo LMS WordPress plugin before 3.4.1, write and execute arbitrary code on the server. A weaker form of the same issue is reachable without an account and yields an arbitrary file write rather…

Potential Impact

Severity is CRITICAL (CVSS 9.9). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.

Exploitability Assessment

Exploitability is assessed as High based on severity and technical exposure profile.

Primary risk drivers: severity and technical exposure profile

Mitigation Recommendations

Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.

Detection & Monitoring

Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.

Business Impact Lens

AI risk score 91/100 (Critical, High) with priority P1 Immediate. Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.

Affected Products

Masteriyo LMS PLUGIN · masteriyo-lms Affected: < 3.4.1 Fixed in: 3.4.1

References

What to do about this

Patch immediately Serious, and reachable without meaningful privilege.

Fix it

Update Masteriyo LMS to 3.4.1 or later.

That is the complete fix. Everything below is what protects you in the meantime.

No Hack Halt control meaningfully contains this one — updating is the remedy. We would rather say so than sell you something that will not help.

Start free

Not sure if you are affected?

Scan your site to see whether it runs Masteriyo LMS, and at which version.

Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.

Scan my site free See what Hack Halt does

Am I affected by this vulnerability?

You are affected if your site runs Masteriyo LMS. Versions below 3.4.1 are vulnerable; that release and later are not.

How do I fix it?

Update Masteriyo LMS to version 3.4.1 or later. That is the complete fix.