sales@hackhalt.com

Home / Threats / CVE-2026-80071

User Registration & Membership - Security Vulnerability (CVE-2026-80071)

CVE-2026-80071

The User Registration & Membership WordPress plugin before 5.2.8 does not properly restrict who may author a membership plan or validate the plan a user attaches to their own account, allowing authenticated users with Author-level access and above to assign themselves an arbitrary role and escalate their privileges to Administrator.

CVE-2026-80071

HIGH CVSS 7.2 Published 2026-09-13 Updated 2026-09-14
AI Risk Elevated (66/100) Active Exploit: No strong signal Published Exploit: No public exploit references Priority: P3 Priority
Severity Band HIGH
CVSS Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Affected Components 1
Reference Links 1
AI Risk Engine Elevated (66/100)
Exploitability Medium
Active Exploitation No strong signal
Published Exploit Status No public exploit references

Threat Timeline

  1. 2026-09-13 CVE published and first recorded in the threat feed.
  2. 2026-09-14 Record updated with latest vulnerability metadata.
  3. 2026-09-21 AI technical context refreshed for mitigation and impact guidance.
  4. Now Monitoring for follow-up changes, linked references, and new related CVEs.

AI Context

Machine-generated threat intelligence

AI Updated 45 days ago

AI enriched 45 days ago (2026-09-21 04:01 UTC)

Technical Summary

The User Registration & Membership WordPress plugin before 5.2.8 does not properly restrict who may author a membership plan or validate the plan a user attaches to their own account, allowing authenticated users with Author-level access and above to assign themselves an arbitrary role and escalate their privileges to Administrator.

Potential Impact

Severity is HIGH (CVSS 7.2). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.

Exploitability Assessment

Exploitability is assessed as Medium based on severity and technical exposure profile.

Primary risk drivers: severity and technical exposure profile

Mitigation Recommendations

Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.

Detection & Monitoring

Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.

Business Impact Lens

AI risk score 66/100 (Elevated, Medium) with priority P3 Priority. Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.

References

What to do about this

Patch on your next cycle Worth fixing, but not ahead of other work.

Fix it

Update User Registration & Membership to 5.2.8 or later.

That is the complete fix. Everything below is what protects you in the meantime.

No Hack Halt control meaningfully contains this one — updating is the remedy. We would rather say so than sell you something that will not help.

Start free

Not sure if you are affected?

Scan your site to see whether it runs User Registration & Membership, and at which version.

Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.

Scan my site free See what Hack Halt does

Am I affected by this vulnerability?

You are affected if your site runs User Registration & Membership. Versions below 5.2.8 are vulnerable; that release and later are not.

How do I fix it?

Update User Registration & Membership to version 5.2.8 or later. That is the complete fix.