Betterdocs - PHP Object Injection (CVE-2024-30226)
CVE-2024-30226
Deserialization of Untrusted Data vulnerability in WPDeveloper BetterDocs.This issue affects BetterDocs: from n/a through 3.3.3.
CVE-2024-30226
CVE-2024-30226
Deserialization of Untrusted Data vulnerability in WPDeveloper BetterDocs.This issue affects BetterDocs: from n/a through 3.3.3.
CVE-2024-30226
Machine-generated threat intelligence
AI Updated 46 days ago
AI enriched 46 days ago (2026-09-18 15:25 UTC)
Deserialization of Untrusted Data vulnerability in WPDeveloper BetterDocs.This issue affects BetterDocs: from n/a through 3.3.3.
Severity is CRITICAL (CVSS 9.0). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.
Exploitability is assessed as High based on low-bar exploit prerequisites.
Primary risk drivers: low-bar exploit prerequisites
Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.
Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.
AI risk score 90/100 (Critical, High) with priority P1 Immediate. Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.
Patch immediately Serious, and reachable without meaningful privilege.
Update Betterdocs to 3.3.4 or later.
That is the complete fix. Everything below is what protects you in the meantime.
Cannot update today? Request / payload inspection (WAF) in Hack Halt ProSecure blocks this class of attack before WordPress processes the request.
Inspect request parameters and bodies for injection, traversal and file-inclusion payloads, and refuse the request rather than logging it.
Scan your site to see whether it runs Betterdocs, and at which version.
Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.
You are affected if your site runs Betterdocs. Versions below 3.3.4 are vulnerable; that release and later are not.
Update Betterdocs to version 3.3.4 or later. That is the complete fix. Until you can update, Request / payload inspection (WAF) in Hack Halt ProSecure contains this class of attack at the request layer.
This is a PHP Object Injection flaw. An attacker who exploits it can construct objects the application never intended, often reaching code execution.