Embedpress - Broken Access Control (CVE-2023-51375)
CVE-2023-51375
Missing Authorization vulnerability in WPDeveloper EmbedPress.This issue affects EmbedPress: from n/a through 3.8.3.
CVE-2023-51375
CVE-2023-51375
Missing Authorization vulnerability in WPDeveloper EmbedPress.This issue affects EmbedPress: from n/a through 3.8.3.
CVE-2023-51375
Machine-generated threat intelligence
AI Updated 47 days ago
AI enriched 47 days ago (2026-09-17 23:14 UTC)
Missing Authorization vulnerability in WPDeveloper EmbedPress.This issue affects EmbedPress: from n/a through 3.8.3.
Severity is MEDIUM (CVSS 4.3). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.
Exploitability is assessed as Low based on low-bar exploit prerequisites.
Primary risk drivers: low-bar exploit prerequisites
Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.
Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.
AI risk score 44/100 (Moderate, Low) with priority P4 Planned. Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.
Patch on your next cycle Worth fixing, but not ahead of other work.
Update Embedpress to 3.8.4 or later.
That is the complete fix. Everything below is what protects you in the meantime.
Cannot update today? Request / payload inspection (WAF) in Hack Halt ProSecure blocks this class of attack before WordPress processes the request.
Inspect request parameters and bodies for injection, traversal and file-inclusion payloads, and refuse the request rather than logging it.
Scan your site to see whether it runs Embedpress, and at which version.
Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.
You are affected if your site runs Embedpress. Versions below 3.8.4 are vulnerable; that release and later are not.
Update Embedpress to version 3.8.4 or later. That is the complete fix. Until you can update, Request / payload inspection (WAF) in Hack Halt ProSecure contains this class of attack at the request layer.
This is a Broken Access Control flaw. An attacker who exploits it can reach actions or data that should have been restricted to someone else.