sales@hackhalt.com

Home / Threats / CVE-2026-0611

WordPress component - Remote Code Execution (CVE-2026-0611)

CVE-2026-0611

Vulnerability CVE-2026-0611 CRITICAL

Spacelabs Healthcare Sentinel versions 10.5.x and higher and 11.x.x before 11.6.0 contain an unauthenticated remote code execution vulnerability through a deprecated .NET Remoting HTTP channel exposed on port 8989 that allows attackers to perform arbitrary file read and write operations by supplying valid .NET URI endpoints. Attackers can write ASPX webshells to the IIS wwwroot directory to achieve unauthenticated remote code execution on the system. Port 8989 is not exposed in a default Sentinel installation; exploitation requires that the .NET Remoting port has been explicitly made network-accessible through deliberate configuration or network policy changes.

CVE-2026-0611

CRITICAL CVSS 9.2 Published 2026-06-02 Updated 2026-07-22
AI Risk Critical (100/100) Active Exploit: No strong signal Published Exploit: No public exploit references Priority: P1 Immediate
Severity Band CRITICAL
CVSS Vector CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Affected Components 1
Reference Links 3
AI Risk Engine Critical (100/100)
Exploitability Very High
Active Exploitation No strong signal
Published Exploit Status No public exploit references

Threat Timeline

  1. 2026-06-02 CVE published and first recorded in the threat feed.
  2. 2026-07-22 Record updated with latest vulnerability metadata.
  3. 2026-06-04 AI technical context refreshed for mitigation and impact guidance.
  4. Now Monitoring for follow-up changes, linked references, and new related CVEs.

AI Context

Machine-generated threat intelligence

AI Updated 151 days ago

AI enriched 151 days ago (2026-06-04 14:41 UTC)

Technical Summary

Spacelabs Healthcare Sentinel versions 10.5.x and higher and 11.x.x before 11.6.0 contain an unauthenticated remote code execution vulnerability through a deprecated .NET Remoting HTTP channel exposed on port 8989 that allows attackers to perform arbitrary file read and write operations by supplying valid .NET URI endpoints. Attackers can write ASPX webshells to the IIS wwwroot directory to achieve unauthenticated remote code execution on the system. Port 8989 is not exposed in a default Sentinel installation; exploitation requires that the .NET…

Potential Impact

Severity is CRITICAL (CVSS 9.2). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.

Exploitability Assessment

Exploitability is assessed as Very High based on remote code execution potential, low-bar exploit prerequisites.

Primary risk drivers: remote code execution potential, low-bar exploit prerequisites

Mitigation Recommendations

Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.

Detection & Monitoring

Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.

Business Impact Lens

AI risk score 100/100 (Critical, Very High) with priority P1 Immediate. Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.

Affected Products

WordPress component COMPONENT · unmapped Affected: < 11.6.0 Fixed in: 11.6.0

References

What to do about this

Patch immediately Serious, and reachable without meaningful privilege.

Fix it

Update WordPress component to 10.5.x or later.

That is the complete fix. Everything below is what protects you in the meantime.

No Hack Halt control meaningfully contains this one — updating is the remedy. We would rather say so than sell you something that will not help.

Start free

Not sure if you are affected?

Scan your site to see whether it runs WordPress component, and at which version.

Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.

Scan my site free See what Hack Halt does

Am I affected by this vulnerability?

You are affected if your site runs WordPress component. Versions below 10.5.x are vulnerable; that release and later are not. No account is needed to exploit this, so a public site is reachable by anyone.

How do I fix it?

Update WordPress component to version 10.5.x or later. That is the complete fix.

What can an attacker actually do?

This is a Remote Code Execution flaw. An attacker who exploits it can run their own code on the server, which is total control of the site.