sales@hackhalt.com

Home / Threats / CVE-2026-22781

TinyWeb - Security Vulnerability (CVE-2026-22781)

CVE-2026-22781

TinyWeb is a web server (HTTP, HTTPS) written in Delphi for Win32. TinyWeb HTTP Server before version 1.98 is vulnerable to OS command injection via CGI ISINDEX-style query parameters. The query parameters are passed as command-line arguments to the CGI executable via Windows CreateProcess(). An unauthenticated remote attacker can execute arbitrary commands on the server by injecting Windows shell metacharacters into HTTP requests. This vulnerability is fixed in 1.98.

CVE-2026-22781

CRITICAL CVSS 10.0 Published 2026-01-12 Updated 2026-01-16
AI Risk Critical (100/100) Active Exploit: Likely Published Exploit: Public exploit references found Priority: P1 Immediate
Severity Band CRITICAL
CVSS Vector CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Affected Components 1
Reference Links 3
AI Risk Engine Critical (100/100)
Exploitability Very High
Active Exploitation Likely
Published Exploit Status Public exploit references found

Threat Timeline

  1. 2026-01-12 CVE published and first recorded in the threat feed.
  2. 2026-01-16 Record updated with latest vulnerability metadata.
  3. 2026-04-09 AI technical context refreshed for mitigation and impact guidance.
  4. Now Monitoring for follow-up changes, linked references, and new related CVEs.

AI Context

Machine-generated threat intelligence

AI Updated 207 days ago

AI enriched 207 days ago (2026-04-09 07:11 UTC)

Technical Summary

TinyWeb is a web server (HTTP, HTTPS) written in Delphi for Win32. TinyWeb HTTP Server before version 1.98 is vulnerable to OS command injection via CGI ISINDEX-style query parameters. The query parameters are passed as command-line arguments to the CGI executable via Windows CreateProcess(). An unauthenticated remote attacker can execute arbitrary commands on the server by injecting Windows shell metacharacters into HTTP requests. This vulnerability is fixed in 1.98.

Potential Impact

Severity is CRITICAL (CVSS 10.0). Depending on deployment context, affected components may be exposed to unauthorized actions or data integrity risk.

Exploitability Assessment

Exploitability is assessed as Very High based on published exploit references, remote code execution potential, low-bar exploit prerequisites.

Primary risk drivers: published exploit references, remote code execution potential, low-bar exploit prerequisites

Mitigation Recommendations

Validate affected product versions, prioritize patching, and monitor references for vendor remediation guidance. If immediate patching is not possible, apply compensating controls and limit exposure of vulnerable surfaces.

Detection & Monitoring

Track authentication anomalies, unexpected file writes, and suspicious plugin API activity around affected components.

Business Impact Lens

Prioritize remediation where affected components process customer data, admin sessions, or Internet-exposed workflows.

Affected Products

TinyWeb PLUGIN · tinyweb Affected: >= 1.98, <= 1.98 Fixed version not specified

References

What to do about this

Patch immediately Serious, and reachable without meaningful privilege.

Fix it

Update TinyWeb to 1.98 or later.

That is the complete fix. Everything below is what protects you in the meantime.

No Hack Halt control meaningfully contains this one — updating is the remedy. We would rather say so than sell you something that will not help.

Start free

Not sure if you are affected?

Scan your site to see whether it runs TinyWeb, and at which version.

Free, no installation, no account. It reads what your site already publishes, then tells you which plugins carry known vulnerabilities and what to do about each one.

Scan my site free See what Hack Halt does

Am I affected by this vulnerability?

You are affected if your site runs TinyWeb. Versions below 1.98 are vulnerable; that release and later are not. No account is needed to exploit this, so a public site is reachable by anyone.

How do I fix it?

Update TinyWeb to version 1.98 or later. That is the complete fix.